- 필수 기능
- 시작하기
- Glossary
- 표준 속성
- Guides
- Agent
- 통합
- 개방형텔레메트리
- 개발자
- Administrator's Guide
- API
- Datadog Mobile App
- CoScreen
- Cloudcraft
- 앱 내
- 서비스 관리
- 인프라스트럭처
- 애플리케이션 성능
- APM
- Continuous Profiler
- 스팬 시각화
- 데이터 스트림 모니터링
- 데이터 작업 모니터링
- 디지털 경험
- 소프트웨어 제공
- 보안
- AI Observability
- 로그 관리
- 관리
",t};e.buildCustomizationMenuUi=t;function n(e){let t='
",t}function s(e){let n=e.filter.currentValue||e.filter.defaultValue,t='${e.filter.label}
`,e.filter.options.forEach(s=>{let o=s.id===n;t+=``}),t+="${e.filter.label}
`,t+=`ID: go-best-practices/redefine-builtin-id
Language: Go
Severity: Info
Category: Best Practices
In programming, it is generally recommended to avoid using built-in names for function or variable names. Here are some reasons why this should be avoided:
To avoid these issues, it is best to choose descriptive and meaningful names for your functions and variables that clearly convey their purpose and behavior. By doing so, you enhance code readability, prevent confusion, ensure future compatibility, and make use of the full range of features and tooling provided by your programming language.
func true() {
false := true
false = false
append = 1
}
func myFunction() {
myVariable := true
myVariable = false
myList = make(int[])
}