In Go programming, it is considered good coding practice to use the is or has prefix instead of get when naming functions that return a boolean value. This convention is suggested to improve code readability and maintainability.
The reason for this recommendation is that functions prefixed with get typically imply that they will return some value. Using get for a function that returns a boolean can be misleading and confusing for other developers who may expect it to return some non-boolean value.
By using the is or has prefix, it explicitly indicates that the function is intended to check the presence or state of a condition and will return a boolean value. This naming convention makes it easier for developers to understand the function’s purpose and appropriately use it in their code.
Non-Compliant Code Examples
funcgetSomething()bool{}
Compliant Code Examples
funchasSomething()bool{}
Seamless integrations. Try Datadog Code Analysis
Datadog Code Analysis
Try this rule and analyze your code with Datadog Code Analysis
How to use this rule
1
2
rulesets:- go-best-practices # Rules to enforce Go best practices.
Create a static-analysis.datadog.yml with the content above at the root of your repository
Use our free IDE Plugins or add Code Analysis scans to your CI pipelines