- 필수 기능
- 시작하기
- Glossary
- 표준 속성
- Guides
- Agent
- 통합
- 개방형텔레메트리
- 개발자
- API
- Datadog Mobile App
- CoScreen
- Cloudcraft
- 앱 내
- 서비스 관리
- 인프라스트럭처
- 애플리케이션 성능
- APM
- Continuous Profiler
- 스팬 시각화
- 데이터 스트림 모니터링
- 데이터 작업 모니터링
- 디지털 경험
- 소프트웨어 제공
- 보안
- AI Observability
- 로그 관리
- 관리
ID: go-best-practices/boolean-get-function-name
Language: Go
Severity: Info
Category: Best Practices
In Go programming, it is considered good coding practice to use the is
or has
prefix instead of get
when naming functions that return a boolean value. This convention is suggested to improve code readability and maintainability.
The reason for this recommendation is that functions prefixed with get
typically imply that they will return some value. Using get
for a function that returns a boolean can be misleading and confusing for other developers who may expect it to return some non-boolean value.
By using the is
or has
prefix, it explicitly indicates that the function is intended to check the presence or state of a condition and will return a boolean value. This naming convention makes it easier for developers to understand the function’s purpose and appropriately use it in their code.
func getSomething() bool {
}
func hasSomething() bool {
}
|
|
For more information, please read the Code Analysis documentation
Identify code vulnerabilities directly in yourVS Code editor
Identify code vulnerabilities directly inJetBrains products